Would you like to react to this message? Create an account in a few clicks or log in to continue.

Bug Reports

+13
Little Vamp
TheDeFIler
Seby
Baron_Von_Bullsh-t
aphrodia81
Aurelli
SHADOWROD
EvilMag
BlueCrab
Moopthehedgehog
MuCast
Wing
Aleron Ives
17 posters

Page 1 of 5 1, 2, 3, 4, 5  Next

Go down

Bug Reports Empty Bug Reports

Post  Aleron Ives Tue Jan 04, 2011 11:45 pm

If you find a bug on the server, please report it here. This post contains both a list of previously fixed bugs, as well as a list of currently known bugs that have not yet been fixed. Revisions with new features are also listed in bold.

Latest revision: r774

Revision History

  1. r301: Gem order corrected (green, yellow, blue, red -> green, red, yellow, blue).
  2. r302: Word Select speech that you send no longer appears twice in the Log Window.
  3. r303: Friendlist sign on and sign off notifications now display the ship of your friend instead of your own.
  4. r304: The legit checker no longer blocks ?SPECIAL WEAPON or negative percentages.
  5. r306: Guild Cards and Simple Mails can be searched even if friends are online on other ships.
  6. r307: The /ll command was added.
  7. r315: Teams no longer desynchronize when legit mode is active.
  8. r320: The /npc command was added.
  9. r337: Challenge mode graves are now translated between Dreamcast and PC clients.
  10. r346: The /ignore and /unignore commands were added.
  11. r356: The leader's Challenge mode grave is now visible to everyone.
  12. r358: Fix Choice Search to let you search for "FOmarl" instead of "FOmar".
  13. r370: The /quit command was added.
  14. r374: The legit checker no longer blocks a ?SPECIAL WEAPON if it has a grind value disallowed in the weapon's tekked state.
  15. r384: Allow name-only S-Rank weapons in legit mode.
  16. r388: Block percentages not divisible by five in legit mode.
  17. r401: Colour chat is now possible with the /cc command.
  18. r426: Block duplicate percentage areas in legit mode.
  19. r427: Fix shield drops being deleted by legit mode.
  20. r436: Quests can now have a minimum and/or maximum number of players requirement.
  21. r467: Prevent extra costumes and classes on GC from crashing Ver.1/2 users.
  22. r469: Prevent extra hair styles on GC from crashing Ver.1/2 users.
  23. r470: Prevent new GC classes from joining Ver.1/GC-compatible teams.
  24. r471: The /ver command now lets you see the current ship revision.
  25. r474: Fix Japanese team names in Guild Card search results.
  26. r498: Prevent the /passwd command from allowing non-ASCII characters.
  27. r510: Add the /search command to search for Guild Card numbers manually.
  28. r516: Fix locked teams always considering the supplied password to be incorrect.
  29. r527: Allow ships to have a pre-configured calendar of events.
  30. r530: Fix locked teams not displaying the password prompt.
  31. r531: Fix the Challenge progress window in DC/PC teams.
  32. r543: Fix disconnecting from the team if an NPC uses an item.
  33. r568: Fix the Dreamcast Word Select list.
  34. r574: Allow players to make automatic character backups when entering a team.
  35. r579: Hide teams from the list that can't be joined.
  36. r600: Fix Word Selects regarding Meseta being treated as invalid; send a blank Challenge rank for Ver.1 players to prevent them from receiving a phantom rank
  37. r606: Add the beginnings of the server-side drop system.
  38. r610: Allow the server to read enemy and object data from PSO's map files for the server-side drop system.
  39. r614: Return to the lobby of origin when exiting a team.
  40. r622: Fix PC crashing when searching DC users in teams with maximum-length names.
  41. r623: Truncate maximum-length DC team names for PC users.
  42. r626: Fix Guild Card search results to display team names in the "Team:" field instead of the "Block:" field.
  43. r627: Fix the /minlvl and /maxlvl commands to not be off by one level.
  44. r641: Allow the server-side drop system to generate rare items.
  45. r643: Add /sdrops command to enable the server-side drop system.
  46. r644: Check server-side drops against the ship's limits file.
  47. r647: Don't allow the same enemy to drop multiple items if multiple players request a drop from it when using the server-side drop system.
  48. r649: Add Guild Card protection to prevent another player from having the same Guild Card number as you.
  49. r664: Allow the second page of team information to show which quest is in progress.
  50. r667: Parse quest maps to allow the server-side drop system to work in quests.
  51. r668: Add a ship configuration flag to determine whether the server-side drop system should drop rare items in quests.
  52. r674: Add a ship configuration flag to allow the server-side drop system to drop 9* "basic" rares from the ItemPT in quests but not enemy-specific rares from the ItemRT.
  53. r686: Add initial support for the Dreamcast's Network Trial Edition.
  54. r722: Update the team's Section ID if the leader disconnects when using the server-side drop system.
  55. r728: If the user is offline when another player sends him a Simple Mail, the message will now be sent to the user's account on the website, and the server will prompt the user to check the website with a Simple Mail the next time he logs on.
  56. r734: Fix the server-side drop system getting disabled when loading a quest.
  57. r744: Fix tools and Meseta failing the legit check when dropping from the server-side drop system.
  58. r768: Add server-side enemy kill tracking.
  59. r773: Disable the server-side drop system in quests to prevent bogus quest drops if the server can't read the quest's maps.
  60. r774: Update the user's enemy kill counts when starting a quest instead of discarding them.


Unfixed Bugs/To Do List

  1. Fix the random server crash when the lobby is full for a while.


Last edited by Aleron Ives on Fri Jan 02, 2015 2:44 pm; edited 11 times in total

_________________
"Fear the HUnewearl."
Bug Reports Awesonic_small
Aleron Ives
Aleron Ives
Socially-Devoid Member
Socially-Devoid Member

Number of posts : 2187
Age : 34
Registration date : 2008-03-24

http://psopalace.funurl.com

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Aleron Ives Tue Jan 04, 2011 11:48 pm

Thanks go out to both Wing and Koneko for thoroughly testing /legit mode to figure out that ?SPECIAL WEAPON was being blocked and to EvilMag for hopping online so we could test the gem order fix with four players. Smile

BlueCrab will update Iselia and Altimira with r304 some time Wednesday morning when nobody is online, so if Christmas mode is off again, you can assume that the ship has been restarted and updated. I'll enable Christmas again when I get up. Razz I'd say we're off to a good start so far. Very Happy

_________________
"Fear the HUnewearl."
Bug Reports Awesonic_small
Aleron Ives
Aleron Ives
Socially-Devoid Member
Socially-Devoid Member

Number of posts : 2187
Age : 34
Registration date : 2008-03-24

http://psopalace.funurl.com

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Wing Wed Jan 05, 2011 4:57 am

Hey, any time. I know the V2 community has always been small the past few years. If you ever need any help with something that is within our abilities, don't hesitate to ask. o:
Wing
Wing
Turbo Member
Turbo Member

Number of posts : 329
Age : 31
Registration date : 2008-04-23

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  MuCast Wed Jan 05, 2011 8:13 am

Yeah, I'd be willing to help as well. Oh yeah, has anyone tried Battle mode to see if there are any problems? Razz
MuCast
MuCast
Uber Member
Uber Member

Number of posts : 760
Age : 29
Registration date : 2008-10-28

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Aleron Ives Wed Jan 05, 2011 1:12 pm

Actually, I was thinking about testing Battle 1 to see if that crazy SCHTServ bug still happens where if you play it a second time, you see your opponent using different weapons than he actually is, and when you kill him, he drops stuff like God/Legs instead of a weapon. xD I think we ought to see if BlueCrab can figure out the lobby crash and Guild Card searching problems first, though. Wink We're also going to try to make the graves in Challenge appear cross-platform, for the lulz. Razz

_________________
"Fear the HUnewearl."
Bug Reports Awesonic_small
Aleron Ives
Aleron Ives
Socially-Devoid Member
Socially-Devoid Member

Number of posts : 2187
Age : 34
Registration date : 2008-03-24

http://psopalace.funurl.com

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Moopthehedgehog Wed Jan 05, 2011 2:26 pm

Dreamcast for to seeing the death-markers?

So long as I don't need to burn a disc for it, I'll test it!

Oh, I had a question, does Bluecrab's server support restoring from saves with less playtime like SCHTserv does?
(I.E. restoring from e-mail saves.)
Moopthehedgehog
Moopthehedgehog
Uber Member
Uber Member

Number of posts : 681
Registration date : 2009-12-11

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Aleron Ives Wed Jan 05, 2011 3:31 pm

Sega's server was the only one that denied the use of copied character data.

_________________
"Fear the HUnewearl."
Bug Reports Awesonic_small
Aleron Ives
Aleron Ives
Socially-Devoid Member
Socially-Devoid Member

Number of posts : 2187
Age : 34
Registration date : 2008-03-24

http://psopalace.funurl.com

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Moopthehedgehog Wed Jan 05, 2011 4:26 pm

Bug (I think): Only 5 download quests are available for the Dreamcast v2. Hero & Daughter and the Triad Maximum attack are not present (I only see the default 5).

I'm using the GD-ROM, as always.
Moopthehedgehog
Moopthehedgehog
Uber Member
Uber Member

Number of posts : 681
Registration date : 2009-12-11

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  BlueCrab Wed Jan 05, 2011 5:02 pm

Moopthehedgehog wrote:Bug (I think): Only 5 download quests are available for the Dreamcast v2. Hero & Daughter and the Triad Maximum attack are not present (I only see the default 5).

I'm using the GD-ROM, as always.
Bleh. Stupid bug. I'll fix it the next time I restart login server (so probably later tonight).

EDIT: It should be fixed now. Please let me know if the fix works right.

BlueCrab
Power Member
Power Member

Number of posts : 155
Age : 35
Registration date : 2011-01-03

http://sylverant.net/

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Moopthehedgehog Wed Jan 05, 2011 7:15 pm

When i go into it, all the quests are there, it seems to work great now. However, if I back out, then I only see the offline quest ship and no others. I can only download a quest and go from there or soft reset to get back to the DC menu.

Nevermind, I connected at a downed shipgate.
Moopthehedgehog
Moopthehedgehog
Uber Member
Uber Member

Number of posts : 681
Registration date : 2009-12-11

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  BlueCrab Wed Jan 05, 2011 7:43 pm

The guild search bug was fixed in r306, and the shipgate restarted (so everything's good to go). Also, the dlq bug was fixed in r305 as well as the lobby client ID ordering. Iselia and Altimira are both running r305, for reference.

BlueCrab
Power Member
Power Member

Number of posts : 155
Age : 35
Registration date : 2011-01-03

http://sylverant.net/

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  EvilMag Sun Jan 09, 2011 9:25 pm

This a bug regarding GC on your ship Ives. Can't seem to make a game cause when I do, I end up here:
Bug Reports DSC02358
(Unless you set it to that.) I tried it on Vega and Crab's ships and it worked fine.
EvilMag
EvilMag
Turbo Member
Turbo Member

Number of posts : 415
Age : 29
Registration date : 2009-03-14

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  SHADOWROD Sun Jan 09, 2011 10:41 pm

Blue Crab explained to me on Dcemulation forum that it happens due to lag because of ship´s different locations and your distance from them...that´s why vega works well, it must be closer to your location ...at least, Iselia does work for you. For my pso plus, it also happens on Iselia, and not on vega.
SHADOWROD
SHADOWROD
Member
Member

Number of posts : 26
Registration date : 2010-06-07

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  BlueCrab Sun Jan 09, 2011 10:48 pm

SHADOWROD wrote: Blue Crab explained to me on Dcemulation forum that it happens due to lag because of ship´s different locations and your distance from them...that´s why vega works well, it must be closer to your location ...at least, Iselia does work for you. For my pso plus, it also happens on Iselia, and not on vega.
The odd thing about that, though, is that Altimira and Iselia are hosted in the same exact place, on the same exact machine, using the same exact binary of ship_server.

That said, usually that "above the ship" thing is related to lag, and sometimes passes after a little while. PSO is very fickle at times with relation to lag. Heck, I think I remember that above the ship thing happening to me back in the day on Sega's server on PSOv1.

BlueCrab
Power Member
Power Member

Number of posts : 155
Age : 35
Registration date : 2011-01-03

http://sylverant.net/

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Aleron Ives Sun Jan 09, 2011 10:55 pm

Being above Pioneer 2 only happens on the Gamecube version. In Ver.1/2, you get to stare out the window of the Hunter's Guild with the pillar just sitting there doing its spinny thing.

_________________
"Fear the HUnewearl."
Bug Reports Awesonic_small
Aleron Ives
Aleron Ives
Socially-Devoid Member
Socially-Devoid Member

Number of posts : 2187
Age : 34
Registration date : 2008-03-24

http://psopalace.funurl.com

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  BlueCrab Sun Jan 09, 2011 11:15 pm

Aleron Ives wrote:Being above Pioneer 2 only happens on the Gamecube version. In Ver.1/2, you get to stare out the window of the Hunter's Guild with the pillar just sitting there doing its spinny thing.
Ah, that's right... Duh, should've remembered that. Laughing

BlueCrab
Power Member
Power Member

Number of posts : 155
Age : 35
Registration date : 2011-01-03

http://sylverant.net/

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  EvilMag Mon Jan 10, 2011 12:02 am

Yeah but everytime I make a game I get stuck up there. At least on v2, I can play.
EvilMag
EvilMag
Turbo Member
Turbo Member

Number of posts : 415
Age : 29
Registration date : 2009-03-14

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Aurelli Wed Jan 12, 2011 2:12 pm

clients from ceasing to synchronize with the leader after a while.

This has only happened to me twice.. both times were in PH
I'm not quite sure I know what I'm talking about I'll admit, but is there a chance it might have something to do with a lot/many different types of monsters?
Maybe too many monsters or items at once..?
Aurelli
Aurelli
Active Member
Active Member

Number of posts : 52
Age : 32
Registration date : 2009-10-07

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Aleron Ives Thu Jan 13, 2011 1:10 am

The desynchronization bug has been fixed!

The short form: Teams will no longer desynchronize when legit mode is enabled. Huzzah! The bug was discovered two days ago, a temporary fix was tested yesterday, and now a permanent fix is in place. That should be the end of it, but if you encounter any other problems, let us know.

The long form, if you're curious:

Spoiler:

_________________
"Fear the HUnewearl."
Bug Reports Awesonic_small
Aleron Ives
Aleron Ives
Socially-Devoid Member
Socially-Devoid Member

Number of posts : 2187
Age : 34
Registration date : 2008-03-24

http://psopalace.funurl.com

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Wing Thu Jan 13, 2011 1:27 am

Oh, wow. You guys fixed that one pretty quick! cheers

Nice work. Very Happy

It'll be nice to use the /legit command again without any problems.

Should something strange happen though, I'll be sure to let you know.
Wing
Wing
Turbo Member
Turbo Member

Number of posts : 329
Age : 31
Registration date : 2008-04-23

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Aleron Ives Fri Feb 04, 2011 10:43 pm

A minor bug with the legit checker has been fixed; grind values on ?SPECIAL WEAPON are no longer checked, so as to not mistakenly flag legit rare drops as hacks if the untekked weapon has a grind value disallowed in the weapon's tekked state.

_________________
"Fear the HUnewearl."
Bug Reports Awesonic_small
Aleron Ives
Aleron Ives
Socially-Devoid Member
Socially-Devoid Member

Number of posts : 2187
Age : 34
Registration date : 2008-03-24

http://psopalace.funurl.com

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  aphrodia81 Tue Feb 08, 2011 10:02 am

This might be minor, because not many use v1, or perhaps not, but I've noticed just today that after I start a room in the "Allow PSO V1" format, when I start up a quest, it won't load. It just hangs at the "Quest is loading" screen, and there isn't even a gauge to show progress.

I've tested it with my characters, and on different quests (Endless Nightmare #3, Lost <insert here>) and the quest wouldn't start. However, when I pick "Pso v2 only" or "PSO PC only," it will work. All of this happens whether I'm solo, or with others, which was when I first noticed it this morning (around 11 am EST).
aphrodia81
aphrodia81
Member
Member

Number of posts : 21
Age : 38
Registration date : 2010-06-20

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Baron_Von_Bullsh-t Tue Feb 08, 2011 10:07 am

I was there man...The freezing and the re-enter...it was fubar man...just fubar...Do people even play V1 online still?
Baron_Von_Bullsh-t
Baron_Von_Bullsh-t
Power Member
Power Member

Number of posts : 165
Age : 36
Registration date : 2010-06-02

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Aleron Ives Tue Feb 08, 2011 2:26 pm

aphrodia81 wrote:This might be minor, because not many use v1, or perhaps not, but I've noticed just today that after I start a room in the "Allow PSO V1" format, when I start up a quest, it won't load. It just hangs at the "Quest is loading" screen, and there isn't even a gauge to show progress.

I've tested it with my characters, and on different quests (Endless Nightmare #3, Lost <insert here>) and the quest wouldn't start. However, when I pick "Pso v2 only" or "PSO PC only," it will work. All of this happens whether I'm solo, or with others, which was when I first noticed it this morning (around 11 am EST).
I wonder if it's a problem with the new quest parsing/DTD... You were on Altimira, I presume?

_________________
"Fear the HUnewearl."
Bug Reports Awesonic_small
Aleron Ives
Aleron Ives
Socially-Devoid Member
Socially-Devoid Member

Number of posts : 2187
Age : 34
Registration date : 2008-03-24

http://psopalace.funurl.com

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Baron_Von_Bullsh-t Tue Feb 08, 2011 2:38 pm

yessum
Baron_Von_Bullsh-t
Baron_Von_Bullsh-t
Power Member
Power Member

Number of posts : 165
Age : 36
Registration date : 2010-06-02

Back to top Go down

Bug Reports Empty Re: Bug Reports

Post  Sponsored content


Sponsored content


Back to top Go down

Page 1 of 5 1, 2, 3, 4, 5  Next

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum